Opened 6 years ago

Closed 5 years ago

#4652 closed Bug (fixed)

Config for disable editor context menu

Reported by: garry.yao Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.5
Component: UI : Context Menu Version:
Keywords: Cc:

Description

We should provide an option for disable context menu in editor, probably porting #311 from v2.

Attachments (3)

4652.patch (22.6 KB) - added by garry.yao 5 years ago.
4652_2.patch (22.1 KB) - added by tobiasz.cudnik 5 years ago.
4652_3.patch (22.1 KB) - added by tobiasz.cudnik 5 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 6 years ago by garry.yao

Actually here we just need to make it possible to disable it by simply remove the plugin itself, no new config introduced.

comment:2 Changed 6 years ago by fredck

  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

comment:3 Changed 5 years ago by fredck

  • Milestone changed from CKEditor 3.3 to CKEditor 3.4

Changed 5 years ago by garry.yao

comment:4 Changed 5 years ago by garry.yao

  • Keywords Confirmed Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

'contextmenu' plugin is no longer required by 'menubutton' thus can be removed from plugin list to reveal the native context menu.

comment:5 Changed 5 years ago by alfonsoml

It seems to me that the overall idea and changes are OK, but due to the number of changes, I would like that someone else could look also at the patch.

comment:6 Changed 5 years ago by alfonsoml

  • Keywords Review- added; Review? removed

There's some error with this patch:

in IE8, select some word and open the context menu, dismiss it, select something else and trying to open the context menu will throw an error. If the second time nothing is selected, the context menu opens, and when it's closed it selects back the first range.

comment:7 Changed 5 years ago by fredck

  • Milestone changed from CKEditor 3.4 to CKEditor 3.5

comment:8 Changed 5 years ago by tobiasz.cudnik

  • Owner changed from garry.yao to tobiasz.cudnik
  • Status changed from review_failed to assigned

I'm taking this one over Garry.

Changed 5 years ago by tobiasz.cudnik

comment:9 Changed 5 years ago by tobiasz.cudnik

  • Status changed from assigned to review

Reason for non unlocked selection on IE was unexecuted onHide listener.

comment:10 Changed 5 years ago by fredck

  • Milestone changed from CKEditor 3.4.1 to CKEditor 3.5

comment:11 Changed 5 years ago by garry.yao

  • Status changed from review to review_failed

There's an error thrown when menu is hide at L145 of menu/plugin.js.

Changed 5 years ago by tobiasz.cudnik

comment:12 Changed 5 years ago by tobiasz.cudnik

  • Status changed from review_failed to review

comment:13 Changed 5 years ago by garry.yao

  • Status changed from review to review_passed

Nice done!

comment:14 Changed 5 years ago by tobiasz.cudnik

  • Keywords Confirmed removed
  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [5937].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy