Opened 10 years ago

Closed 10 years ago

#4674 closed Bug (fixed)

Undo not working for Smileys, Page break and Anchor after HTML source mode.

Reported by: Joe Kavanagh Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.2
Component: Core : Undo & Redo Version: 3.0.1
Keywords: IBM Confirmed Cc: dchojna@…

Description

  1. Enter a Smiely, page break or anchor.
  2. Click Source to enter HTML mode.
  3. Click Source again to enter Rich Text mode.
  4. Click Undo and observe the simley, page break or anchor is not removed.

Change History (3)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Discussion added
Milestone: CKEditor 3.1

Caused by the unordered attributes retrieved from innerHTML, which confuse the duplication examination, considering that any sort of fixes will introduce performance degrade at this moment, we'll have it under investigation.

comment:2 Changed 10 years ago by Garry Yao

Keywords: Confirmed added; Discussion removed
Milestone: CKEditor 3.2
Owner: set to Garry Yao
Status: newassigned

This issue is now fixed by #4622.

comment:3 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy