Opened 8 years ago

Closed 8 years ago

#4724 closed Bug (fixed)

[IE8] Create link hypertext

Reported by: Sébastien Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: CKEditor 3.2
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE Review+ Cc:

Description

(sorry for my english level)

Using IE8 ,in the window for create link, if i paste "http://www.google.com" with right click mouse, and i valid with mouse. The link src contain two "http://"

Attachments (1)

4724.patch (954 bytes) - added by Alfonso Martínez de Lizarrondo 8 years ago.
Proposed patch

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by Sébastien

Summary: Crate link hypertext and IE8[IE8] Crate link hypertext

comment:2 Changed 8 years ago by Sébastien

Summary: [IE8] Crate link hypertext[IE8] Create link hypertext

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added; ie8 link right click paste removed
Milestone: CKEditor 3.1CKEditor 3.2
Version: SVN (CKEditor)

Confirmed with IE8. Ok with FF.

Steps to reproduce:

  1. Copy the text "http://www.google.com/" to the clipboard.
  2. Select some text in the editor.
  3. Open the Link dialog.
  4. Right click the URL field and select "Paste".
  5. Confirm the dialog, closing it.
  6. Check the source.

Changed 8 years ago by Alfonso Martínez de Lizarrondo

Attachment: 4724.patch added

Proposed patch

comment:4 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

I've included just a call to onChange() in the commit method of the control to be sure that it is updated properly.

This is a simple patch, another solution could be to modify the commit method of the CKEDITOR.ui.dialog.textInput prototype so all text inputs have this change, but I don't know if it's worth the effort

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Looks like a good and simple way to solve the problem.

comment:6 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed with [4917]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy