Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4771 closed Bug (invalid)

Text size changes even if font size remains same

Reported by: Jitendra Kumar Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.0.1
Keywords: Cc:

Description

  1. Go to nightly build

http://nightly.ckeditor.com/4675/_samples/skins.html

  1. Type something
  1. select any style like 'heading'
  1. change the font size to let's say 10
  1. Do it again. That is change the font size to 10 again. Basically select the previous size from drop down.

Now notice, even though I've selected the same font size, it actually gets bigger

Change History (5)

comment:1 Changed 9 years ago by Jitendra Kumar

Please note, 'select' some text before changing font size in step 4.

comment:2 Changed 9 years ago by Garry Yao

Resolution: invalid
Status: newclosed

Far from a bug actually, clicking on a marked item in dropdown instruct the editor to remove that style.

comment:3 in reply to:  2 Changed 9 years ago by Jitendra Kumar

Resolution: invalid
Status: closedreopened

Replying to garry.yao:

Far from a bug actually, clicking on a marked item in dropdown instruct the editor to remove that style.

Are you serious? I haven't seen a single editor online/offline which changes text size if you re-select the same font size. Your logic couldn't be applied to font-size dropdown menu. I agree it's fine with buttons where you change the style of the button to tell user that button would apply/de-apply some function.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1
Resolution: invalid
Status: reopenedclosed

The fact is that there is no way to remove the size. Because of this, we replicated the same solution we've built in all toolbar combos so we have a standard way to make it work. I'm sure users that expect things working differently will easily learn how to use the combos properly.

comment:5 in reply to:  4 Changed 9 years ago by Jitendra Kumar

Replying to fredck:

The fact is that there is no way to remove the size. Because of this, we replicated the same solution we've built in all toolbar combos so we have a standard way to make it work. I'm sure users that expect things working differently will easily learn how to use the combos properly.

OK. I reported it as a bug because it was an unexpected behavior. Thanks for explanation.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy