Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4799 closed Bug (fixed)

SCAYT interferes on collapsed selection styling

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: 3.0.1
Keywords: Review+ Cc: WebSpellChecker.net

Description

  1. Load the following HTML:
    <p>asdasdasd</p>
    
  1. Enable SCAYT. The "asdasdasd" text will get underlined.
  1. Click in the middle of "asdasdasd".
  1. Select any style, for example Bold.
  1. Type text.

The style will not be applied to the typed text.

Attachments (1)

firebug-profile-keydown.png (10.7 KB) - added by Garry Yao 10 years ago.
Screenshot of Firebug Profile Panel

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Garry Yao

The bold style is opened successfully, while on the subsequent key press, SCAYT seems to be intercepting the keystroke and making selection alternations, proved by the attached screenshot (created on the first keystroke that follows the 'Bold' command).
I would ask SpellChecker to please check your engine for this bug.

Changed 10 years ago by Garry Yao

Attachment: firebug-profile-keydown.png added

Screenshot of Firebug Profile Panel

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Component: Core : StylesUI : Spell Checker

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.x

comment:4 Changed 10 years ago by WebSpellChecker.net

Keywords: Review? added; Confirmed removed

The problem fixed in new SCAYT core. To test it trunk (or nightly build) should be configured to use it:

config.scayt_srcUrl = "http://svc.spellchecker.net/spellcheck31/lf/scayt/scayt22.js";

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed
Resolution: fixed
Status: newclosed

Confirmed to be fixed with the updated SCAYT service.

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Milestone: CKEditor 3.xCKEditor 3.3
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy