Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4800 closed Bug (fixed)

Opera: when SCAYT is enabled, it is impossible to create new paragraph

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: 3.0.1
Keywords: Confirmed Opera Cc: WebSpellChecker.net

Description

Steps to reproduce

  • type some text
  • enable SCAYT
  • press enter, type some text
  • result: new paragraph is not created, text is added at the end of previous paragraph, an error is reported in the error console:
    Event thread: keyup
    Error:
    name: TypeError
    message: Statement on line 3677: Cannot convert undefined or null to Object
    stacktrace:   Line 3677 of linked script http://svc.spellchecker.net/spellcheck3/lf/scayt/_base3.xd.js
        while(node!=_3ad.test(node.nodeName)&&!node.previousSibling){
      ...  Line 47 of linked script http://svc.spellchecker.net/spellcheck/lf/scayt/scayt1.js
        function(){return _119.apply(_118,arguments||[]);}
    

Change History (7)

comment:1 Changed 9 years ago by Wiktor Walc

Just a note that it is also impossible to create a new list item by pressing the enter key when SCAYT is enabled.

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

comment:3 Changed 9 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:4 Changed 9 years ago by Garry Yao

SpellChecker.net was intended to disable SCAYT on Opera.(#5145) So this could probably become Wontfix?

comment:5 Changed 9 years ago by WebSpellChecker.net

SpellChecker can confirm that this is not priority issue.

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Is not possible to enable SCAYT on Opera now. For now, SCAYT will not be compatible with it.

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.xCKEditor 3.3
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy