Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4848 closed Bug (fixed)

IE: cannot type anything altghough cursor is blinking in the editing area

Reported by: Wiktor Walc Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: 3.0.1
Keywords: Confirmed IE 3.0.2 Review+ Cc:

Description

Happens only if you click with your mouse at the beginning of the editing area. Confirmed in IE8 @ Win XP/SS3

Steps to reproduce

  • Starting with the following source:
    <p>This is some <strong>sample text</strong>. You are using</p>
    
  • switch to wysiwyg mode
  • point your mouse straight before "This" and press the button
  • result: cursor is blinking in the editing area, but if you type anything, it will not appear in the editor.

This bug existed also in 3.0.1, but in 3.0.1 the cursor was not visible in the editing area at all.

Attachments (1)

4848.patch (836 bytes) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: 3.0.2 added
Milestone: CKEditor 3.1
Owner: set to Frederico Caldeira Knabben
Status: newassigned

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 4848.patch added

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added

The idea comes from V2, with a different implementation.

comment:3 Changed 9 years ago by Garry Yao

The patch doesn't break anything for me even though I'm still unable to reproduce this bug, I would ask the Wiktor to conduct the final review.

comment:4 Changed 9 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [4755].

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

We have the following error after the fix:

  1. Load the following HTML:
<table border="1" cellpadding="1" cellspacing="1" style="width: 200px">
	<tbody>
		<tr>
			<td>
				AAA</td>
			<td>
				BBB</td>
		</tr>
		<tr>
			<td>
				CCC</td>
			<td>
				DDD</td>
		</tr>
		<tr>
			<td>
				EEE</td>
			<td>
				FFF</td>
		</tr>
	</tbody>
</table>
  1. Select the text in the two first rows.
  2. Open the context menu for the selection and select Row > Delete Rows
  3. Do CTRL+Z to undo. Error thrown here.

This has been fixed with [4758].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy