Opened 12 years ago

Closed 12 years ago

#4851 closed Bug (fixed)

IE : Delete table rows may throw a js error

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.2
Component: General Version: 3.0.1
Keywords: Confirmed IE Review+ Cc:

Description

  1. Load the following HTML:
<table border="1" cellpadding="1" cellspacing="1" style="width: 200px">
	<tbody>
		<tr>
			<td>
				AAA</td>
			<td>
				BBB</td>
		</tr>
		<tr>
			<td>
				CCC</td>
			<td>
				DDD</td>
		</tr>
		<tr>
			<td>
				EEE</td>
			<td>
				FFF</td>
		</tr>
	</tbody>
</table>
  1. Select the entire text of the two first rows with the mouse. This is an important step. The everything from AAA to DDD must be selected.
  1. Open the context menu for the selection.
  1. Select Row > Delete Rows.

A JavaScript error is thrown.

Attachments (1)

4851.patch (2.0 KB) - added by Garry Yao 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Garry Yao

Attachment: 4851.patch added

comment:1 Changed 12 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

This's a common case of inadequate selection error because of DOM manipulation (remove rows), by managing the selection after row deletion (e.g. put cursor into next row), this problem will be resolved.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:3 Changed 12 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5012].

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy