Opened 8 years ago

Closed 8 years ago

#4859 closed Bug (fixed)

Flash object elements are broken in FF

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: 3.0
Keywords: Confirmed Review+ Cc:

Description (last modified by Garry Yao)

Confirmed on FF 3.5.5 @ WinXP/SP3.

Steps to reproduce

  • start with
    <p><object width="660" height="525">
    <param name="movie" value="http://www.youtube.com/v/HwNXvQ2OK_k&hl=pl_PL&fs=1&color1=0x234900&color2=0x4e9e00&border=1"></param>
    <param name="allowFullScreen" value="true"></param>
    <param name="allowscriptaccess" value="always"></param>
    <embed src="http://www.youtube.com/v/HwNXvQ2OK_k&hl=pl_PL&fs=1&color1=0x234900&color2=0x4e9e00&border=1"
     type="application/x-shockwave-flash" allowscriptaccess="always"
     allowfullscreen="true" width="660" height="525"></embed>
    </object></p>
    
  • switch to source mode
  • result:
    <p><object height="525" width="660">
    <param name="movie" value="http://www.youtube.com/v/HwNXvQ2OK_k&amp;hl=pl_PL&amp;fs=1&amp;color1=0x234900&amp;color2=0x4e9e00&amp;border=1" />
    </object>
    <param name="allowFullScreen" value="true" />
    <param name="allowscriptaccess" value="always" />
    <embed allowfullscreen="true" allowscriptaccess="always" height="525" src="http://www.youtube.com/v/HwNXvQ2OK_k&amp;hl=pl_PL&amp;fs=1&amp;color1=0x234900&amp;color2=0x4e9e00&amp;border=1" 
    type="application/x-shockwave-flash" width="660">
    </embed></p>
    
    (<embed> and some <param> elements are outside <object> element)

Attachments (1)

4859.patch (1.3 KB) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by Wiktor Walc

Description: modified (diff)

This does not happen when params are created this way:

<param name="allowFullScreen" value="true" />

it only happens when params are created like this:

<param name="allowFullScreen" value="true"></param>

(YouTube does like that).

comment:2 Changed 8 years ago by Garry Yao

Description: modified (diff)
Milestone: CKEditor 3.1CKEditor 3.3

Defer it, at least it works for valid HTML.

Changed 8 years ago by Garry Yao

Attachment: 4859.patch added

comment:3 Changed 8 years ago by Garry Yao

Keywords: Review? added
Milestone: CKEditor 3.3CKEditor 3.1
Owner: set to Garry Yao
Status: newassigned

The fixing seems to be simple, so let's have it back in 3.1...
Including the latest patch from #4856 for easy reviewing.

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Please do not mix fixes from other tickets.

comment:5 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [4790].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy