Opened 10 years ago

Closed 9 years ago

#4884 closed Bug (fixed)

Spell Check As You Type (SCAYT) causes IE to Scroll

Reported by: Jared Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: 3.0.2
Keywords: Confirmed Cc: Jared, WebSpellChecker.net

Description

The following issue happens when using Internet Explorer (tested IE6 and IE8), both CKEditor 3.0.1 and 3.0.2:

When text is typed in a CKEditor editor and I scroll to the top of the page, after about 2.5 seconds, the page will automatically scroll back down to the CKEditor editor. This has to do with the spell check as you type happening on a delay. When the spell check triggers, it shifts the page down to the editor. Any ideas on how to eliminate this problem (while keeping SCAYT turned on)? Can the delay be adjusted from the time text is entered to the time the spelling is checked? IE6 is the target browser.

Thank you, Jared

Change History (7)

comment:1 Changed 10 years ago by Jared

Keywords: scayt scroll added

comment:2 Changed 10 years ago by Jared

Cc: Jared added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net added
Component: GeneralUI : Spell Checker
Keywords: scayt scroll removed

comment:4 Changed 9 years ago by Garry Yao

The current SCAYT engine is not testable in IE, please give proper priority to fix it.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.3

Confirmed. It happens when enabling SCAYT with some misspelled word, as well as when typing misspelled words.

comment:6 Changed 9 years ago by WebSpellChecker.net

This bug was fixed with scayt core updates. See #5551 to update scayt url.

comment:7 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: newclosed

Works for me after #5551.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy