Ticket #4887 (closed Bug: duplicate)

Opened 5 years ago

Last modified 3 months ago

Paste: Font face and sizes not recognised on pasted content from word

Reported by: damo Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.1
Keywords: IBM Cc: satya_minnekanti@…

Description

When copying formatted text (font face & font size set) from Word, the font face and/or size is not recognized by the editor. Paste config options used:

config.pasteFromWordRemoveFontStyles = false; 
config.pasteFromWordRemoveStyles = false;

In the case of the font size, the pasted content uses points whereas the editor uses pixels.

Attachments

fonts.doc (23.5 KB) - added by j.swiderski 22 months ago.

Change History

comment:1 Changed 5 years ago by garry.yao

  • Keywords Confirmed added
  • Milestone changed from CKEditor 3.1 to CKEditor 3.2

We don't suppose to target font-face and size normalization at this point, leave it open for further investigation.

comment:2 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

comment:3 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.3 to CKEditor 3.x

Defer it due to the complexity of this feature.

comment:4 Changed 5 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:5 Changed 4 years ago by paho

  • Owner set to paho
  • Status changed from confirmed to assigned

comment:6 Changed 4 years ago by paho

  • Status changed from assigned to new
  • Owner paho deleted

comment:7 Changed 4 years ago by satya

  • Cc satya_minnekanti@… added

comment:8 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.1

This issue was duplicated and confirmed in #7797

comment:9 Changed 22 months ago by lynne_kues

This has become a high priority customer issue for us.

Changed 22 months ago by j.swiderski

comment:10 Changed 22 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

Code that is seen by browser is:

<p class="MsoNormal"><span style="font-size:14.0pt" lang="EN-US">Times New Roman,
14</span></p>

<p class="MsoNormal"><span style="font-family:&quot;Comic Sans MS&quot;" lang="EN-US">Comic
Sans Serif, 12</span></p>

<p class="MsoNormal"><span style="font-size:16.0pt;font-family:Georgia" lang="EN-US">Georgia</span><span style="font-size:16.0pt;font-family:Georgia" lang="EN-US">, 16</span></p>
  1. It seems Times New Roman isn't passed to browser. If there is no font specified then there is no way for editor to recognize font. I don't see error here.
  1. In second case font-family is comic sans ms while editor has comic sans ms,cursive defined. Since font doesn't match it isn't recognized. This has already been described in #9964.
  1. Font family Georgia isn't recognized because of the same reason as in point two. Font in editor is set to "georgia, serif" while font passed from Word is "georgia".

Font sizes in points aren't defined in editor by default and this is why they aren't recognized and this is again #9964 issue.

Since both problems concern feature mentioned in #9964 I’m closing this ticket as duplicate.

DUP of #9964.

Last edited 22 months ago by j.swiderski (previous) (diff)

comment:11 Changed 3 months ago by wwalc

I'm not sure if it's a full duplicate of #9964 because the information about the size and color is lost during PFW for the attached document?

Win 7, Office 2010

config.pasteFromWordRemoveFontStyles = false; 
config.pasteFromWordRemoveStyles = false;

IE11, ACF enabled, CKE 4.4.6

<p><span style="font-size:14pt">Times New Roman, 14</span></p>

<p><span style="font-family:comic sans ms">Comic Sans Serif, 12</span></p>

<p><span style="font-family:georgia,serif; font-size:16pt">Georgia</span><span style="font-family:georgia,serif; font-size:16pt">, 16</span></p>

IE11, ACF disabled, CKE 4.4.6

<p style="margin: 0in 0in 0pt;"><span style="font-size: 14pt;"><font color="#000000" face="Times New Roman">Times New Roman, 14</font></span></p>

<p style="margin: 0in 0in 0pt;"><span style="font-family: &quot;Comic Sans MS&quot;;"><font color="#000000" size="3">Comic Sans Serif, 12</font></span></p>

<p style="margin: 0in 0in 0pt;"><span style="font-family: &quot;Georgia&quot;,&quot;serif&quot;; font-size: 16pt;"><font color="#000000">Georgia</font></span><span style="font-family: &quot;Georgia&quot;,&quot;serif&quot;; font-size: 16pt;"><font color="#000000">, 16</font></span></p>
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy