Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#7797 closed Bug (duplicate)

Paste from Word does not recognize fonts

Reported by: Lynne Kues Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.1
Keywords: IBM Cc:

Description

Run the attached example. Open the attached word document and copy contents and paste into editor. Place cursor on each of the lines.

Notice that the font is not recognized. The font name/size drop downs do not get updated to reflect the font, even though these are fonts that the editor is aware of.

Attachments (2)

fonts.doc (23.5 KB) - added by Lynne Kues 9 years ago.
paste-word-ticket.html (481 bytes) - added by Lynne Kues 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by Lynne Kues

Attachment: fonts.doc added

Changed 9 years ago by Lynne Kues

Attachment: paste-word-ticket.html added

comment:1 Changed 9 years ago by Jakub Ś

Status: newconfirmed
Version: 3.4.23.1

Of course options

config.pasteFromWordRemoveFontStyles=false;
config.pasteFromWordRemoveStyles=false;

have to be set. Fonts and thier sizes haven't been recognized form CKEditor version 3.1 (since these options were introduced)

comment:2 Changed 8 years ago by Satya Minnekanti

This looks like a duplicate of #4887

comment:3 Changed 8 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

Duplicate of #4887

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy