Opened 10 years ago

Closed 10 years ago

#4980 closed Bug (fixed)

img border=0 not working

Reported by: johngoodell Owned by: Minh Nguyen
Priority: Normal Milestone: CKEditor 3.2
Component: General Version: 3.1
Keywords: Confirmed Review+ Cc:

Description

Try setting Image Properties -> Border=0, click OK - went back to properties, nothing in border text box.

Then tried linking an image - automatically defaults to a border - went to Image Properties, entered 0 in Border, clicked OK - nothing changes. This WORKS in 3.0, but since installing latest version (last night) it doesn't.

Is OK for any other value entered in this field (tried image border=1 and it saves correctly).

Attachments (3)

border_bug.png (42.4 KB) - added by johngoodell 10 years ago.
4980.patch (3.2 KB) - added by Minh Nguyen 10 years ago.
This bug also happen with hspace and vspace, too. The reason of problem is we have an error in case logic check variable with zero value.
4980_2.patch (4.3 KB) - added by Minh Nguyen 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by johngoodell

Broken in both FF3 and IE8

Changed 10 years ago by johngoodell

Attachment: border_bug.png added

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.2

Confirmed. Setting border to zero is currently removing the border styles from the image. It should instead set the border style to "none".

Border styles must be removed only when leaving the border field empty.

Changed 10 years ago by Minh Nguyen

Attachment: 4980.patch added

This bug also happen with hspace and vspace, too. The reason of problem is we have an error in case logic check variable with zero value.

comment:3 Changed 10 years ago by Minh Nguyen

Keywords: Review? added
Owner: set to Minh Nguyen
Status: newassigned

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

Changed 10 years ago by Minh Nguyen

Attachment: 4980_2.patch added

comment:5 Changed 10 years ago by Minh Nguyen

Resolution: fixed
Status: assignedclosed

Fixed with [4980].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy