Opened 8 years ago

Closed 7 years ago

#5064 closed Bug (invalid)

Enter button is not handled properly while activating toolbar controls.

Reported by: Pranav Prakash Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version:
Keywords: Oracle Cc: Senthil, Pranav

Description

Enter is not captured for the toolbar buttons which causes the form post automatically. To reproduce the issue, follow the following steps:

  1. Press Alt+F10 to activate toolbar control. Varify that source button is selected.
  1. Press Enter button to switch to source mode.

You will observe that form post is happening. Same thing is happening for the "Maximize" button too.

Sample file to reproduce the issue is attached with this ticket.

Attachments (2)

replacebycode_enter.html (2.9 KB) - added by Pranav Prakash 8 years ago.
Sample file to reproduce the issue
replacebycode_enter.2.html (2.6 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Adjusted test file

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by Pranav Prakash

Attachment: replacebycode_enter.html added

Sample file to reproduce the issue

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x
Priority: HighNormal

For now, your custom key handling system should check whether the key is being pressed inside elements that should not cause form posting.

comment:2 Changed 7 years ago by Garry Yao

Resolution: invalid
Status: newclosed
Version: 3.1

Again, others might find the event bubbling useful, we can't just kill it only because of the way you choose to implement application.

comment:3 Changed 7 years ago by Senthil

If the user is using keyboard keys to access the toolbar control, he would not be able to access the control at all. Becuase the form post is happening while pressing the enter key. Since it is an accessibility related(critical to us), we need a patch for this.

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: replacebycode_enter.2.html added

Adjusted test file

comment:4 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Milestone: CKEditor 3.x

The file shows how to detect if the event is directed at the form elements or to something else in the page and avoid submitting the form in that case.

comment:5 Changed 7 years ago by Senthil

Priority: NormalHigh
Resolution: invalid
Status: closedreopened

This is creating unnecessary form post in our pages and our page functionality is controlled by the different framework and that cannot be changed for this new behavior. So this issue needs to be addressed ASAP since it is a critical issue.

comment:6 Changed 7 years ago by Senthil

Please close this ticket since the workaround(received from Garry) fixes the reported problem.

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

Priority: HighNormal
Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy