Ticket #5086 (closed Bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Long HTML in source mode in IE8 scrolls up when editor loses focus

Reported by: kevinw Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version: SVN (CKEditor) - OLD
Keywords: Cc: kevin@…,

Description

Steps to reproduce:

  • Use MSIE 8 as your browser; ensure compatibility mode is disabled
  • Visit the latest nightly build (I used http://nightly.ckeditor.com/5000/_samples/replacebyclass.html)
  • View the page source and copy the HTML to your clipboard (any medium-large HTML page will do) then close the source view
  • Click the Source button in the editor instance
  • Paste the contents of the clipboard buffer into the editor pane
  • Scroll to the bottom of the editor. You will now see something similar to the attached file "scrollpos_orig.png"
  • Now click the cursor somewhere outside the editor area, e.g. on the window body.

Expected Behavior:

Editor scroll position does not change (screen appearance remains the same)

Actual Behavior:

Editor scrolls upward an arbitrary amount toward the top of the source document. Repeatedly clicking inside/outside the editor pane scrolls further up the document in most cases. See attached screenshot, "scrollpos_moved.png".

Browser/OS:

Microsoft Internet Explorer 8 (I am using release 8.0.6001.18702) on Windows XP SP2

Notes:

This was previously reported by someone else in defect #4775 (and possibly others), which was marked as invalid. However, both that and this defect have the same root cause, which is a callback executed in the "source" textarea when the blur event is fired. The change that "fixed" #4775 appears to be the removal of manually firing onblur when onmouseout fired, but it did not resolve the core issue.

Attachments

scrollpos_orig.png (23.7 KB) - added by kevinw 4 years ago.
Appearance of the scroll position before clicking outside the editor
scrollpos_moved.png (23.1 KB) - added by kevinw 4 years ago.
Appearance of the scroll position after clicking outside the editor pane

Change History

Changed 4 years ago by kevinw

Appearance of the scroll position before clicking outside the editor

Changed 4 years ago by kevinw

Appearance of the scroll position after clicking outside the editor pane

comment:1 Changed 4 years ago by kevinw

  • Status changed from new to closed
  • Resolution set to duplicate

Looks like this defect has already been reported multiple times in #4761 , #4817 , #4762 , and possibly others. I am closing and marking as duplicate.

comment:2 Changed 4 years ago by fredck

  • Milestone CKEditor 3.x deleted
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy