Ticket #5111 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

JAWS not reading tool bar controls properperly while navigating with arrow keys

Reported by: pranav Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: Accessibility Version: 3.1
Keywords: Confirmed Oracle IBM Review+ Cc: Senthil, Pranav

Description

Press Alt+F10 to focus toolbar. Use Tab and Shift+Tab to navigate through tool bar. You will observe that JAWS is reading all controls properly. Now use arrow key to navigate through toolbar. You will observe that you are not able to navigate and JAWS is not reading the highlighted control properly i.e. if highlighted control is Preview then it is reading it like "P" "R" "E" "V" "I" "E" "W" and not as "Preview".

This issue was reproducible in nightly build too with Internet Explorer 8 and Firefox 3.6.

Attachments

5111.patch (1.7 KB) - added by garry.yao 4 years ago.

Change History

comment:1 Changed 4 years ago by garry.yao

  • Priority changed from High to Normal
  • Status changed from new to assigned
  • Owner set to garry.yao
  • Milestone set to CKEditor 3.2

It's related to the VisualPC Mode of JAWS, ideally user should always in PC mode on editor toolbar.

We're trying to introduce automatic PC Mode turning on in aria branch.

comment:2 Changed 4 years ago by garry.yao

  • Keywords Confirmed added

We've implemented the correct role (application) on editor chrome to indicate non-VPC mode for screen readers, while JAWS only respect this role on <BODY> element, but obviously that we couldn't do so otherwise the entire page will be polluted.

comment:3 Changed 4 years ago by garry.yao

  • Keywords IBM added
  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

We would defer it to see if Freedom Scientific could give us some feedback.

comment:4 Changed 4 years ago by garry.yao

  • Status changed from assigned to new
  • Owner garry.yao deleted

Changed 4 years ago by garry.yao

comment:5 Changed 4 years ago by garry.yao

  • Status changed from new to assigned
  • Owner set to garry.yao

The patch partially fixes the problem in FF but not in IE.

comment:6 Changed 4 years ago by garry.yao

  • Keywords Review? added

comment:7 Changed 4 years ago by fredck

  • Keywords Review+ added; Review? removed

Considering that the arrows are not the standard way to navigate through items (the TAB is the normal choice), and that this looks like a limitation/bug on either the browser or the AT, let's at least reduce the impact of it to fewer users.

comment:8 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed
  • Milestone changed from CKEditor 3.3 to CKEditor 3.4

Fixed with [5459], new bug #5669 opened for the unresolved IE problem.

comment:9 Changed 4 years ago by garry.yao

  • Milestone changed from CKEditor 3.4 to CKEditor 3.3
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy