Opened 9 years ago

Closed 9 years ago

#5112 closed Bug (duplicate)

CKEditor : Browse server button on the link tab of the image dialogue launches config.filebrowserImageBrowseUrl instead of config.filebrowserBrowseUrl

Reported by: Tony Owned by:
Priority: Normal Milestone:
Component: General Version: 3.1
Keywords: Cc:

Description

Hi, I've found what I think is a problem, at least it is for me. CKEditor's image dialogue has three tabs at the top. Image Info, Link and Advanced. When you use the config.filebrowserBrowseUrl and config.filebrowserImageBrowseUrl api calls, in the image dialogue the url specified by : config.filebrowserImageBrowseUrl is used for both of the browse server buttons in the image dialogue. On the image info tab and the link tab.

The problem is that the browse button on the link tab should call config.filebrowserBrowseUrl instead of config.filebrowserImageBrowseUrl because you can link an image to any file. It's extremely rare to want to link an image to an image other than itself.

So if you use config.filebrowserImageBrowseUrl to filter only images in your file browser, when you switch to the link tab to add a link, you can only browse images.

I grabbed a nightly CKEditor snapshot two nights ago and the problem was there.

Maybe a new api call would help sort this out but I'm not sure it's a great default setting. Please let me know if you consider this a bug and you will fix it because I will need to fix it only here if not.

Thanks, Tony

Change History (1)

comment:1 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: image dialogue browse server filebrowserImageBrowseUrl removed
Resolution: duplicate
Status: newclosed
Version: SVN (CKEditor)3.1

dup of #4987

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy