Opened 10 years ago

Closed 10 years ago

#5119 closed Bug (fixed)

disabled icons are not being marked when focused while navigation with the keyboard

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: Accessibility Version: 3.1
Keywords: Confirmed Review+ Cc:

Description

if you navigate with the keyboard to a disabled icon it seems that the focus is lost. this is not incorrect, yet it should be marked somehow.

Attachments (2)

5119.patch (4.3 KB) - added by Garry Yao 10 years ago.
5119_2.patch (8.9 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.3

This one applies to the context menu as well.

Changed 10 years ago by Garry Yao

Attachment: 5119.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:3 Changed 10 years ago by Sa'ar Zac Elias

Keywords: Review+ added; Review? removed

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review+ removed

The reviewer role is supposed to be taken by the core team.

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

Office 2003 in IE (8) doesn't get any border for disabled icons, in high contrast they are slightly dimmed.
With Kama skin, in IE and Firefox, the selected button isn't marked with a border (doesn't matter the state so it should be a different bug)

In High contrast mode there's no change, disabled buttons aren't marked when focus is on them

Changed 10 years ago by Garry Yao

Attachment: 5119_2.patch added

comment:6 in reply to:  5 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

Replying to alfonsoml:

Office 2003 in IE (8) doesn't get any border for disabled icons, in high contrast they are slightly dimmed.

The 'dimming' issue is fixed in the new patch.

With Kama skin, in IE and Firefox, the selected button isn't marked with a border (doesn't matter the state so it should be a different bug)

It's by design.

In High contrast mode there's no change, disabled buttons aren't marked when focus is on them

Same behavior with normal state buttons is replicated in the new patch.

comment:7 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:8 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5245].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy