Opened 10 years ago

Closed 10 years ago

#5118 closed Bug (fixed)

Arrow keys navigation in RTL languages is incorrect

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: Accessibility Version: 3.1
Keywords: Confirmed Review+ Cc:

Description

It is expected that the left arrow key will go to the icon that is to the left of the current, but in RTL languages the left arrow is actually mobing to the icon that is to the right of the current.
in other words, the navigation arrow keys should be switched when using RTL language.

Attachments (2)

5118.patch (1.6 KB) - added by Garry Yao 10 years ago.
5118.2.patch (2.4 KB) - added by Sa'ar Zac Elias 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.3

comment:2 Changed 10 years ago by Sa'ar Zac Elias

Applies to the context menu as well.

comment:3 Changed 10 years ago by Sa'ar Zac Elias

..and Smiley dialog.

Changed 10 years ago by Garry Yao

Attachment: 5118.patch added

comment:4 in reply to:  2 ; Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

Replying to Saare:

Applies to the context menu as well.

In which sense? The sub menu keystrokes is correct for me in trunk.

comment:5 in reply to:  4 Changed 10 years ago by Sa'ar Zac Elias

Keywords: Review- added; Review? removed

Replying to garry.yao:

Replying to Saare:

Applies to the context menu as well.

In which sense? The sub menu keystrokes is correct for me in trunk.

I don't remember what was the problem with the context menu, so ignore it for now. i'll let you know if i encounter this bug again.
Anyway, R- because L14 in specialchar dialog should be like L10 in smiley dialog in the patch, and the bug ahould be fix in the editor toolbar as well.

Changed 10 years ago by Sa'ar Zac Elias

Attachment: 5118.2.patch added

comment:6 Changed 10 years ago by Sa'ar Zac Elias

Keywords: Review? added; Review- removed

comment:7 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed
Resolution: fixed
Status: assignedclosed

:) Thank you Saare, you're a wonderful JavaScript developer[[BR]] Fixed with [5235].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy