Opened 10 years ago

Closed 10 years ago

#5132 closed Bug (fixed)

Formatting automatically applied to all characters/words when only single character/word is highlighted

Reported by: Pranav Prakash Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: Core : Styles Version: 3.1
Keywords: Oracle Review+ Cc: Senthil, Pranav

Description

Write some text e.g. A B C in editor area. Select "A" and click on underline button. It underlines the text. Now select "B" and click on underline button. It underlines "B" correctly. Now select "C" and click on italic button. You will observe that entire text including "A" and "B" is changed to italic. Same is the case with words.

This issue was reproducible in nightly build with Internet Explorer 8 and Firefox 3.6.

Attachments (1)

5132.patch (792 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.3

comment:2 Changed 10 years ago by Garry Yao

Keywords: Pending added; Confirmed removed

Works for me with the following source on both IE and Firefox:

<p>A B C</p>

Any other clue?

comment:3 in reply to:  2 Changed 10 years ago by Pranav Prakash

Replying to garry.yao:

Works for me with the following source on both IE and Firefox:

<p>A B C</p>

Any other clue?

I was able to reproduce the issue in nightly build with IE8. Can you please varify it once again?

comment:4 Changed 10 years ago by Pranav Prakash

Please refer to this video demonstrating the issue.

http://www.youtube.com/watch?v=S3pqXM8atAc

I was using latest nightly build with IE8.

Changed 10 years ago by Garry Yao

Attachment: 5132.patch added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

Confirmed, have to be very care to select only the character (without including space) to reproduce the bug.

The patch is trying to cover a logic whole in 'range::enlarge' method.

Ticket Test added:
run OR view source.

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Pending Review? removed

comment:7 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5220].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy