Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5165 closed Bug (worksforme)

CKEDITOR_BASEPATH has no affect on CKEDITOR.basePath

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM WorksForMe Cc: Joe Kavanagh, Damian

Description

The CKEDITOR_BASEPATH global should change the value of CKEDITOR.basePath because the later could be used in the code to setup paths.

Attachments (2)

5165_TC.html (672 bytes) - added by Frederico Caldeira Knabben 9 years ago.
Test page
5165_A_TC.html (1.3 KB) - added by Joe Kavanagh 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

This one is a follow up of #5099.

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 5165_TC.html added

Test page

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe added; Confirmed removed

This one works for me.

I've attached a test page for it. Note that I'm loading the main script from a local URL, but I'm setting the CKEDITOR_BASEPATH var to a remote URL. Both the CKEDITOR.basePath and the specific editor setting reflect the CKEDITOR_BASEPATH change.

@JoeK, do you have more information about it?

Changed 9 years ago by Joe Kavanagh

Attachment: 5165_A_TC.html added

comment:3 Changed 9 years ago by Joe Kavanagh

With a CKEditor install at http://localhost/ckeditor and setting CKEDITOR_BASEPATH to the relative URL of '/ckeditor/', CKEDITOR.basePath returns the absolute path http://localhost/ckeditor. Should CKEDITOR.basePath return a relative URL if CKEDITOR_BASEPATH is set to a relative URL? I've attached a test page that sets the smiley_path using CKEDITOR_BASHPATH, CKEDITOR.basePath and CKEDITOR.getUrl. Only CKEDITOR_BASEPATH results in a relative URL.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

Ah ok, now it's clearer.

The CKEDITOR.basePath value will "always" point to a full path. This is specified in the documentation. In cases of absolute URL, the editor will resolve it to a full URL. This is by design.

If you need settings, like smiley_path, to not use full URLs, you should not rely on CKEDITOR.basePath for it, setting then with the absolute URL directly.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy