Ticket #5171 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Dialogs with lists do not have proper labels for lists

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: Accessibility Version: SVN (CKEditor) - OLD
Keywords: IBM Confirmed Cc: Joek

Description

The following dialogs have lists but the list labels are not read correctly by JAWS:

  • smiley (reads as undefined)
  • special character (generic Options label used)
  • templates (generic Options label used)

Change History

comment:1 Changed 4 years ago by fredck

  • Keywords Pending added

The Smiley dialog has been fixed with [5138] so it uses the generic "Options" label for it.

@damo, considering that the "Options" label is contextual, it looks like a good label for the list. What would you expect instead, and why?

comment:2 Changed 4 years ago by damo

The expectation here would be that the label for the options should indicate what kind of options are selectable. In this case sighted users know that there is just one list in the dialog, but a JAWS user won't know if this is list one of one or if there are other options in the dialog. Making the label explicit would remove any doubt.

comment:3 Changed 4 years ago by fredck

  • Keywords Confirmed added; Pending removed
  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

Ok, sounds reasonable. Moving it to the 3.3 as it involves adding new entries to the language file.

comment:4 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from new to assigned

comment:5 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [5239].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy