Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5185 closed Bug (wontfix)

FF—Styles, Font Name and Font Size are not sticky

Reported by: Damian Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: IBM CantFix Cc:

Description (last modified by Frederico Caldeira Knabben)

New issue.

To reproduce the defect:

  1. Select font name and font size options in font name and font size list boxes.
  1. Go in to the body of the editor , type the text you will see that text is typed with the font name and size we have selected.
  1. Go to next line by pressing enter. See that the options still remain.
  1. Go to previous line and go to to end of it, using keyboard navigation (arrows and 'end' button). See that the options in font name and font sizes are removed.
  1. Now go back to next line see that the options in font name and font size are removed.

Change History (3)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: CantFix added
Resolution: wontfix
Status: newclosed

We always had this behavior in the editor, since the beginning. The fact is that styles are not sticky for collapsed selections. When hitting ENTER in step 3, you actually create a collapsed selection in the second line. Then, when moving the caret in step 4, the styled selection get lost.

This behavior is hardly fixable bu our side, as it depends on the caret navigation, which is controlled by the browser itself.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy