Opened 9 years ago

Closed 6 years ago

#5186 closed Bug (fixed)

IE7 - setting a width results in editor jumping to top of screen on click

Reported by: Daniel Rendall Owned by:
Priority: Normal Milestone:
Component: General Version: 3.1
Keywords: Cc:

Description

1) Put attached file 'jumpingDemo.html' in the _samples directory.

2) View in IE7 (or IE8, then use developer tools to switch to Browser Mode: IE7, Document Mode: IE7 Standards)

3) Scroll down so the first editor is in the middle of the screen somewhere. This editor has {width: "100%"} in the CKEDITOR.replace() call.

4) Click in the first editor below the line of text. It should jump to the top of the screen.

5) Scroll down to the second editor (this is inside a p with style="width: 100%") and click in it; you should get the same jumping behaviour.

6) Scroll down to the third editor and click in it - it should stay where it is. This has no width settings.

7) If you switch to IE7 in Quirks mode, you don't get the jumping. Also, it is fine in IE6, IE8 and Firefox.

This is an issue because if there are several small CKEditor instances on screen at once, having the 'clicked' editor jump to the top of the screen is confusing.

This has been verified with the nightly build 5155.

Attachments (1)

jumpingDemo.html (4.8 KB) - added by Daniel Rendall 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by Daniel Rendall

Attachment: jumpingDemo.html added

comment:1 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: newclosed

No longer reproducible.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy