Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5197 closed Bug (fixed)

IE: page reload throws error

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.2
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE Cc:

Description

(3.2.x Branch)

  1. Load a sample.
  2. In the browser page, open a different URL.
  3. Click the browser back button.

A js error is thrown.

This also happens when refreshing the page.

Change History (3)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: newassigned

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [5159].

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Just to keep track of this...

This ticket took several hours to get fixed. Considering it's a regression, it should have been easier, but IE was acting really weirdly here.

The main issue has always being there since [4583]. But, somehow, IE decided to make things work until the button plugin changes introduced with [4896]. I can't explain why, but the changed code was preventing IE to be buggy here.

The fix that came out is a combination of several tickets and fixes that are related to data loading. All previous issues have been considered, and it has been thoroughly tested to avoid issues.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy