Opened 8 years ago

Closed 7 years ago

#5224 closed Bug (fixed)

The Toolbar has been Frozen, textarea uneditable

Reported by: realvalkyrie Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE? Cc:

Description

the code as follows:

<B><FONT face=Tahoma size=2><SPAN style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; FONT-FAMILY: Tahoma">De:</SPAN></FONT></B><FONT size=2><SPAN style="FONT-SIZE: 10pt; FONT-FAMILY: Tahoma"> Devz <BR><B><SPAN style="FONT-WEIGHT: bold">Enviado el:</SPAN></B> MartZ<BR><B><SPAN style="FONT-WEIGHT: bold">Para:</SPAN></B> Mary Lua<BR><B><SPAN style="FONT-WEIGHT: bold">Asunto:</SPAN></B> RV: Documents</SPAN></FONT><FONTFACE="MS PGothic?><BR>Dear Devito,</SPAN></FONT><FONT face="Times New Roman" size=3><SPAN style="FONT-SIZE: 12pt"><BR>ADSDF</SPAN></FONT>

Attachments (2)

5244.patch (583 bytes) - added by Garry Yao 8 years ago.
5224_2.patch (564 bytes) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by realvalkyrie

if replace the invalid html tag "FONTFACE" to "FONT FACE" it's work perfect

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added; Frozen Uneditable removed
Milestone: CKEditor 3.xCKEditor 3.3

Confirmed in IE only. Works well with FF.

Simply paste the provided HTML in the source view and move back to wysiwyg. The toolbar gets stuck, as well as the editor editing.

comment:3 Changed 8 years ago by Minh Nguyen

if replace the invalid html tag "FONTFACE" to "FONT FACE" it's work perfect

We haven't FONTFACE tag, we have a FONT tag and FACE attribute. http://www.w3.org/TR/html4/index/elements.html

Works well with FF

In this case, FF (Safari, Chrome) ignore invalid tags. You can try "XYZ" tag or "Nguyen" tag it still display well.

comment:4 Changed 8 years ago by realvalkyrie

fredck's description is exactly right。 3Q 4 All reply

comment:5 Changed 8 years ago by Sa'ar Zac Elias

The line 'window.parent.CKEDITOR._contentDomReadyeditor1?( window ); ' is also appended.
I found out it happens because of the unclosed tag produced, and not because of an invalid tag.
'<FONTFACE="MS PGothic?>' - instead of quote mark there is a question mark, which breaks the HTML. here's an example:

<FONTFACE="MS PGothic?><FONT face="Times New Roman" size=3>"ADSDF

the parser is parsing it as:

<FONTFACE="
MS PGothic?><FONT face=
"
Times New Roman"
 size=3>
"
ADSDF

so it looks like an unclosed tag.

Changed 8 years ago by Garry Yao

Attachment: 5244.patch added

comment:6 Changed 8 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:7 Changed 8 years ago by Sa'ar Zac Elias

With this patch, paste the following into source:

<FONTFACE="MS PGothic?><FONT face="Times New Roman" size=3>"ADSDF

Switch to WYSIWYG mode. there is no content in the editor.
Switch back to Source mode. there is a code inside.
Switch again to WYSIWYG mode. now there is a content in the editor.

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3CKEditor 3.4

I'm not going on a detailed review for now, but the patch looks plain wrong. Deferring.

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignednew

I've just spent 2 hours on reviewing and research on this issue. We must make it in a way that the invalid tag will be simply ignored, instead of trying to use it somehow... of course, without affecting performance.

I'll be proposing something.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 5224_2.patch added

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed

While testing this patch, I haven't noticed any performance impact.

comment:11 Changed 7 years ago by Frederico Caldeira Knabben

Status: newassigned

comment:12 Changed 7 years ago by Frederico Caldeira Knabben

Status: assignedreview

comment:13 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:14 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [5740].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy