Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#5300 closed Bug (invalid)

Formatting not retained after pasting text from MS Word

Reported by: Pranav Prakash Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.1
Keywords: Oracle Cc: Senthil, Pranav

Description

Following formatting items are not retained after pasting text from MS Word:

  1. Font Name
  2. Font Size
  3. Foreground Color
  4. Background Color

Also sometimes space is removed between words. Refer the attached screenshot for more details. I am attaching a sample doc file to reproduce the issue. This issue was reproducible in IE8 with latest nightly build.

Attachments (2)

PFW.PNG (20.5 KB) - added by Pranav Prakash 10 years ago.
Screenshot
Sample.doc (19.5 KB) - added by Pranav Prakash 10 years ago.
Sample doc file to reproduce the issue

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Pranav Prakash

Attachment: PFW.PNG added

Screenshot

Changed 10 years ago by Pranav Prakash

Attachment: Sample.doc added

Sample doc file to reproduce the issue

comment:1 Changed 10 years ago by Garry Yao

Resolution: invalid
Status: newclosed

Following formatting items are not retained...

Though some of the styles are removed by default, config option is introduced to retain them.

Also sometimes space is removed between words

Duplicate of #4746.

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Component: Core : PastingPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy