Opened 7 years ago

Closed 7 years ago

#5335 closed Bug (fixed)

Several lines' formatted data will be merged to one line when we apply Numbers/Bullets

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.4.1
Component: UI : Toolbar Version: 3.2
Keywords: IBM Cc: Damian, joek

Description

To reproduce the defect

  1. Open ajax sample and type some 4 lines of text( eg: test 1 test 2 test 3 each on a diff line)
  1. Select all the lines and apply Formatting paragraph format option to them.
  1. Now click on Numbers/Bullets Icon

Expected Result:we should see that Numbers/Bullets is applied to the lines

Actual Result: All the four lines of data are merged in to a single line.

Attachments (3)

5335.patch (2.1 KB) - added by Garry Yao 7 years ago.
5335_2.patch (3.3 KB) - added by Garry Yao 7 years ago.
5335_3.patch (3.3 KB) - added by Sa'ar Zac Elias 7 years ago.
Same patch, updated to the current revision

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by Garry Yao

Keywords: Pending added

Select all the lines and apply Formatting paragraph format option to them.

Do you mean 'Formatted' (pre) format option?

comment:2 Changed 7 years ago by Satya Minnekanti

yes that is the option i meant

comment:3 Changed 7 years ago by Garry Yao

Keywords: Confirmed added; Pending removed
Milestone: CKEditor 3.3CKEditor 3.x

Converting pre-formatted content to list should behave just like apply bock style - with line break preserved, but it's not of high priority, since at least we have the right result by first apply "Paragraph" on it before convert to list.

comment:4 Changed 7 years ago by Satya Minnekanti

Milestone: CKEditor 3.xCKEditor 3.3

Yes it should behave like block style, but doesn't at the moment.

I don't understand the justification for treating it as low priority, considering that it doesn't work as the feature is meant to work.

Changed 7 years ago by Garry Yao

Attachment: 5335.patch added

comment:5 Changed 7 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Milestone: CKEditor 3.3CKEditor 3.4

The <pre> block is a special case in the editor as it deals with raw text, unlike other blocks, where line breaks are treated differently. It behaves differently in the editor. For example, if you switch from <pre> to <p> with a collapsed selection, the entire <pre> is converted, not only the line with the caret.

We should have the same behavior here, having the entire <pre> being moved inside an <li>, just like we're doing now with the headings tags. So, in the ticket tc, we would end up with a single <ul><li><pre>...</pre></li></ul> result.

I would understand a different behavior only if it would be possible to have lists inside <pre>, which is not true,

Changed 7 years ago by Garry Yao

Attachment: 5335_2.patch added

comment:7 Changed 7 years ago by Garry Yao

Keywords: Review? added; Review- removed

...the entire <pre> is converted, not only the line with the caret.

Ok, it's a reasonable proposal as it matches the browser's native create list command also.

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4CKEditor 3.5

comment:9 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Confirmed removed
Status: reviewreview_passed

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5335_3.patch added

Same patch, updated to the current revision

comment:10 Changed 7 years ago by Tobiasz Cudnik

Resolution: fixed
Status: review_passedclosed

Fixed with [5875].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy