Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5355 closed Bug (invalid)

Opening a dialog causes silent exception

Reported by: Antti Leppä Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.2
Keywords: HasPatch Cc:

Description (last modified by Alfonso Martínez de Lizarrondo)

Opening a dialog (Image dialog for example) causes exception which is silently consumed by try - catch block but javascript debuggers like firebug still break on the error.

this is caused by access to undefined index (-1) in "focusList" in plugins/dialog/plugin.js:286 and could be fixed by adding:

if (current > -1)

before the

focusList[ current ].getInputElement().$.blur();

line

The bug was discovered with Firefox 3.5.8 (Firebug 1.5.3) / Linux 64bit

Change History (3)

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Description: modified (diff)
Keywords: HasPatch added
Milestone: CKEditor 3.4
Priority: LowNormal
Summary: Opening a dialog causes crashOpening a dialog causes silent exception

comment:2 Changed 10 years ago by Garry Yao

Resolution: invalid
Status: newclosed

It's an by purpose try...catch used here instead of a bug.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy