Opened 8 years ago

Closed 8 years ago

#5356 closed Bug (fixed)

Scayt options dialog doesn't work with prototype.js enabled environments

Reported by: Antti Leppä Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: 3.2
Keywords: Confirmed HasPatch Cc: WebSpellChecker.net

Description

When using CKEditor in prototype.js enabled environments SCAYT plugin options dialog opening crashes.

This is caused by plugins/scayt/dialogs/options.js:218

for ( i in buttons )

Normally this clause iterates over all items within a array but in prototype enabled environments this causes loop to iterate also over all extended methods thus causing following doc.getById( button) to fail

This problem can be fixed by changing line 218 into:

for ( i = 0; i < buttons.length; i++ )

The problem was discovered with Prototype 1.6.1

Change History (4)

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Confirmed added
Milestone: CKEditor 3.3

comment:2 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: HasPatch added

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net added

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [5322].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy