Opened 10 years ago

Closed 8 years ago

#5417 closed Bug (invalid)

Spell checker window doesn't close after correcting words

Reported by: Christian Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version:
Keywords: Cc:

Description

Using WinXP, IE7.0, CKEditor 3.2

When having some misspelled words and running the Aspell type spellchecker, the check dialog won't close when finished. It works with WinXP, FF, CKEditor3.2

It seems as if I add an alert in aspell.js,

function oSpeller_OnFinished(dialog, numberOCorrections)
{
        if (numberOCorrections > 0)
        {
                 editor.focus();
                 editor.fire('saveSnapshot'); // Best way I could find to trigger undo steps.
                 dialog.getParentEditor().setData(document.getElementById(textareaId).value);
===>>>           alert ("oSpeller_OnFinished" );
                 editor.fire('saveSnapshot'); // But there's a blank one between!
         }
         dialog.hide();
}

it works!? When I remove it, the dialog stays open.

If I run the spellcheck with no misspelled words, it closes (since numberOCorrections is 0 i suppose).

Reproducible: every time.
Add editor to page
Enter misspelled words
Start spellchecker dialog
Replace words
When finished, dialog stays open.

Attachments (2)

CKEditor_start.jpg (14.9 KB) - added by Christian 10 years ago.
Start position with example data
CKEditor_dialog_stayed.jpg (29.2 KB) - added by Christian 10 years ago.
After correcting words, the dialog stays open, corrected words sent back to editor.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Christian

Attachment: CKEditor_start.jpg added

Start position with example data

Changed 10 years ago by Christian

Attachment: CKEditor_dialog_stayed.jpg added

After correcting words, the dialog stays open, corrected words sent back to editor.

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net added
Component: GeneralUI : Spell Checker
Milestone: CKEditor 3.x

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:3 Changed 9 years ago by WebSpellChecker.net

Cc: WebSpellChecker.net removed

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Status: newpending

aspell.js? Which spell checker are you talking about?

comment:5 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Officially only Spellchecker.net is supported. Rest is just user choice and thus his/hers task to integrate it correctly.

Closing the ticked as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy