Opened 10 years ago

Closed 10 years ago

#5416 closed Bug (fixed)

[[IE]] we can't delete the Table on a Saved Page

Reported by: Satya Minnekanti Owned by: brooks
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.2
Keywords: confirm Review+ Cc: Damian, joek

Description

To reproduce the defect

  1. Open Ajax sample.
  1. Insert a Table and enter the text in Table Cells.
  1. Click on Remove Editor button to save the Page.
  1. Click on Create Editor button to open the page again.
  1. Go in to one of Table cells and delete the text in one of the Table Cell.
  1. Open Table Context menu and Click on Delete Table Option.

Expected Result:

See that the Table is deleted and you are able to save the page.

Actual Result:

Table is deleted but we are getting an Error & i have attached a Screen shot of the Error and when we click on Remove Editor button to save the Page we get the same Error again.

When i click on Remove Editor button for the Second Time it saves the page but i could still see the Table that i have deleted before.

Tested on IE 6&7

Attachments (2)

IE Error.jpg (779.8 KB) - added by Satya Minnekanti 10 years ago.
5416.patch (767 bytes) - added by brooks 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Satya Minnekanti

Attachment: IE Error.jpg added

comment:1 Changed 10 years ago by Garry Yao

Keywords: Pending added

WFM in both IE6 and IE7, screencast is preferred to demonstrate it.

comment:2 Changed 10 years ago by Damian

This is quite reproducible on my side too. I was able to reproduce this using the steps provided. The error is given in the lower left corner of the IE browser.

We will look into providing a screencase. If someone else could verify this in the meantime that would be great.

comment:3 Changed 10 years ago by Garry Yao

We still need a screencast on this bug.

comment:4 Changed 10 years ago by Satya Minnekanti

i don't know the reason why you are asking for a screencast. The Steps are self explanatory & straightforward and we all at IBM can reproduce the defect just by following the steps.

We can reproduce this on IE 6 & 7.

comment:5 Changed 10 years ago by brooks

Keywords: Confirmed added; Pending removed
Owner: set to brooks
Status: newassigned

confirmed on win7,IE8

comment:6 Changed 10 years ago by brooks

it's simple to reproduce now

  1. open ajax sample
  2. insert a table
  3. right click one cell to delete the table, the error throw out!

comment:7 Changed 10 years ago by Wiktor Walc

Confirmed following the original instructions given by satya on IE7/Vista and IE6/Win2003.

Changed 10 years ago by brooks

Attachment: 5416.patch added

comment:8 Changed 10 years ago by brooks

Keywords: Review? added; IBM Confirmed removed

this bug occur when CKEDITOR.enterMode = CKEDITOR.ENTER_BR
it is dangerous to remove body element in IE,this behavior damaged our snapshot(redo/undo) system

comment:9 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

Configuration options should be specified as part of the reproducing pre-conditions.

comment:10 Changed 10 years ago by brooks

Keywords: confirm added
Resolution: fixed
Status: assignedclosed

agree with Garry, I happen work on the ENTER_BR mode or else couldn't reproduce the bug
fixed with http://dev.fckeditor.net/changeset/5387/ 5387

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy