Opened 9 years ago

Closed 6 years ago

#5476 closed Bug (wontfix)

Enter key before sub list not right

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Discussion Cc:

Description

Reproducing Procedures

  1. Load any of the sample page and fill the editor with the following contents:
     <ol>
    	<li>
    		item1</li>
    	<li>
    		&nbsp;
    		<ol>
    			<li>
    				item2</li>
    		</ol>
    	</li>
    </ol>
    
  2. Place the cursor at the beginning of the second list item (empty content) and press 'Enter' key;
  • Expected Result:
     <ol>
    	<li>
    		item1</li>
    </ol>
    <p>
    	&nbsp;</p>
    <ol>
    	<li>
    		item2</li>
    </ol>
    
  • Actual Result:
      <ol>
    	<li>
    		item1</li>
    	<li>
    		&nbsp;</li>
    	<li>
    		&nbsp;
    		<ol>
    			<li>
    				item2</li>
    		</ol>
    	</li>
    </ol>
    

Change History (2)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Discussion added

I have some doubts about. The fact is that that item is not really empty... it contains a sublist. I think the current behavior is ok.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: newclosed

This issue expired. However, I reported #10247 because this there is a separate issue on Webkits.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy