Opened 10 years ago

Closed 9 years ago

#5478 closed Bug (duplicate)

[IE] Impossible to place the caret after images at the end of the contents

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Cc:

Description

Environment

All IE versions

Reproducing Procedures

  1. Load any of the sample page and fill the editor with the following contents:
    <table>
    	<tbody>
    		<tr>
    			<td>
    				text <img src="http://dev.fckeditor.net/chrome/site/logos.gif" /></td>
    		</tr>
    	</tbody>
    </table>
    
  • Expected Result: It should be able to place the cursor after the image.
  • Actual Result: It's not possible to place cursor after the image with either mouse or keyboard.

Change History (7)

comment:1 Changed 10 years ago by Garry Yao

Same thing happens to list item:

<ol>
	<li>
		text<img src="http://dev.fckeditor.net/chrome/site/logos.gif" />^</li>
</ol>

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added

As described at #5791, this is a generic problem. It happens also with paragraphs:

<p>text <img src="http://dev.fckeditor.net/chrome/site/logos.gif" /></p>

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Summary: [IE] Cursor after the last image in table cell problem[IE] Impossible to place the caret after images at the end of the contents

comment:4 Changed 9 years ago by joolee

It works for CKEditor samples because IE8 renders these pages using Compatibility Mode. If you were to activate Compatibility Mode manually for ckeditor.com/demo page, you'll see that it works correctly.

I propose to increase priority on this bug.

comment:5 Changed 9 years ago by Garry Yao

#6392 has been marked as DUP.

comment:6 Changed 9 years ago by Tim Fluehr

Is there any status update on this?

FYI - I verified that this is still an issue with the latest nightly with IE8. IE9 appears to no longer have a problem.

comment:7 Changed 9 years ago by Wiktor Walc

Resolution: duplicate
Status: confirmedclosed

Duplicate of #3899.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy