Opened 10 years ago

Closed 8 years ago

Last modified 7 years ago

#3899 closed Bug (wontfix)

Navigating problem in IE8 after image added

Reported by: Evgeny Satanovsky Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0 RC
Keywords: IE8 IBM VendorFix Cc: Kevin Grandon, satya_minnekanti@…, Tim Fluehr, Dinu, ruud@…, director@…

Description

Browser name and OS: Windows XP, in IE 8 only.

Steps to reproduce: Go to the end of the lest line (pay attention there is no text after your cursor). Add picture. go to the text before the picture. try to move your cursor to write text after the picture. You'll find out it's not possible.

Attachments (1)

CkEditor.jpg (35.8 KB) - added by Evgeny Satanovsky 10 years ago.
Steps to reproduce

Download all attachments as: .zip

Change History (20)

comment:1 Changed 10 years ago by Garry Yao

Keywords: WorksForMe added
Version: CKEditor 3.0 RC

WFM, could you provide more detail?

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Version: CKEditor 3.0 RC

I'm reverting the incorrect version change. This is an important information.

Changed 10 years ago by Evgeny Satanovsky

Attachment: CkEditor.jpg added

Steps to reproduce

comment:3 Changed 9 years ago by feufeldk

We are expiriencing the same problem. It can also be reproduced in the demo application (currently version 3.2) on ckeditor.com using IE8 and performing the steps which were attached by jenka1980.

comment:4 Changed 9 years ago by joolee

It works for CKEditor samples because IE8 renders these pages using Compatibility Mode. If you were to activate Compatibility Mode manually for ckeditor.com/demo page, you'll see that it works correctly.

I propose to increase priority on this bug.

comment:5 Changed 8 years ago by Wiktor Walc

Status: pendingconfirmed

comment:6 Changed 8 years ago by Wiktor Walc

Cc: Kevin Grandon satya_minnekanti@… added

Marked #7774 and #6031 as duplicate.

comment:7 Changed 8 years ago by Wiktor Walc

#5656 marked as duplicate.

comment:8 Changed 8 years ago by Wiktor Walc

Cc: Tim Fluehr Dinu added
Keywords: IE added
Milestone: CKEditor 3.6.1

The following tickets were also duplicates: #5478, #6392, #5791.

comment:9 Changed 8 years ago by Wiktor Walc

Note that it does not only affect smileys, but all kind of images, including fake elements for iframes and flash.

comment:10 Changed 8 years ago by Garry Yao

Keywords: IE8 added; IE removed

This's an infamous bug of IE8 (only) that affects all object type elements at the end of all block, while fortunately it should be possible to workaround with managed selection.

comment:11 Changed 8 years ago by Satya Minnekanti

Keywords: IBM added

comment:12 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.1

comment:13 Changed 8 years ago by Wiktor Walc

Cc: ruud@… added

comment:14 Changed 8 years ago by Wiktor Walc

Cc: director@… added

comment:15 Changed 8 years ago by Garry Yao

Keywords: VendorFix added

comment:16 in reply to:  15 Changed 8 years ago by Satya Minnekanti

Replying to garry.yao:

@garry.yao could you please add the ticket that you logged with Micrrosaoft for this issue

comment:17 Changed 8 years ago by Garry Yao

Resolution: wontfix
Status: confirmedclosed

It's senseless for an IE8 bug report as the issue is not in IE9, so it's more of a wontfix case.

comment:18 Changed 7 years ago by yiminghe

this problem can be hacked : #8446

comment:19 Changed 7 years ago by Jakub Ś

#4788 was marked as duplicate

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy