Opened 8 years ago

Closed 8 years ago

#7774 closed Bug (duplicate)

Inserting image in IE8 at end of content disables ability to jump to end of content

Reported by: Brandon Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE8 Cc: satya_minnekanti@…

Description

Sorry for the title - the issue is a touch tricky to describe in a title field like this.

Issue can be duplicated on the online demo running 3.5.3: http://ckeditor.com/demo

Issue description: If you insert an image at the end of the content area in IE8, you cannot then put your cursor after the image. You cannot click after the image, and you cannot click before the image and hit 'End' on your keyboard (the cursor jumps to right before the image).

Steps to reproduce (using IE8):

1) Select everything in the content editable area and delete it (you can reproduce with the existing content, but we can use a simpler test case)

2) Type in "test"

3) Click the smilie button and click on one of the smilies (you can alternatively use the image browser to insert a link to an image)

4) Click in the text and change "test" to "text"

5) Try to get your cursor after the image. You cannot click after it, and if you click before it and hit 'End' the cursor jumps to right before the image. There is no way to get your cursor after the image to continue typing.

Here is a short video showing my attempts: http://screencast.com/t/zCjklGDS

Change History (3)

comment:1 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:2 Changed 8 years ago by Jakub Ś

Keywords: IE8 added
Status: newconfirmed
Version: 3.5.33.0

Placing smiley behind sample text in replacebycode will also do.

Hasn't been working in IE8 from CKEditor version 3.0

comment:3 Changed 8 years ago by Wiktor Walc

Resolution: duplicate
Status: confirmedclosed

Duplicate of #3899.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy