Opened 8 years ago

Closed 7 years ago

#5656 closed Bug (duplicate)

IE8 - Cursor can not move to the end of the last smiley in CK Editor

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: IBM Cc: Damian, joek, jamcunni@…

Description

To reproduce the defect:

  1. Open Ajax sample.
  1. Use smiley dialog & insert two or more smileys.
  1. Move your cursor to the beginning of the line with the smiley.
  1. Use your arrow keys or "End" to move the cursor to the end of the line

Expected Result:

Cursor is at the end of the line after the last smiley.

Actual Result:

Cursor is placed before the last smiley instead of after the smiley.

Attachments (1)

cursor at start of last smiley.JPG (153.3 KB) - added by Satya Minnekanti 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Garry Yao

Milestone: CKEditor 3.3

We're full with 3.3, please DO NOT targeting new tickets to this release any more.

comment:2 Changed 7 years ago by Damian

Please add this to 3.5.

comment:3 Changed 7 years ago by Garry Yao

Status: newpending

Now I was unable to reproduce this bug.

comment:4 Changed 7 years ago by James

Cc: jamcunni@… added

comment:5 in reply to:  3 Changed 7 years ago by Satya Minnekanti

Replying to garry.yao:

Now I was unable to reproduce this bug.

I could still reproduce this issue in IE8 on nightly build.

Changed 7 years ago by Satya Minnekanti

comment:6 Changed 7 years ago by Satya Minnekanti

I was using IE8 in Non Compatibility view & i am attaching a screen shot of the cursor position after step 4.

comment:7 Changed 7 years ago by Damian

Is there any update to this issue?

comment:8 Changed 7 years ago by Wiktor Walc

Resolution: duplicate
Status: pendingclosed

Duplicate of #3899.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy