Opened 10 years ago

Closed 10 years ago

#5657 closed Bug (fixed)

IE: The browser BACK button is not working properly

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE Review+ Cc:

Description

Regression. Confirmed with IE8:

  1. Load any page, like http://www.google.com.
  2. Load the replacebyclass sample in the same browser.
  3. Click the browser BACK button. Note that the editor contents disappear.
  4. Click the browser BACK button again. The previous page is loaded.

Expected results: the previous page should be loaded on step 3.

Attachments (1)

5657.patch (1.7 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

In fact, with the current trunk, an error is also thrown. Such error disappears after #5181.

comment:2 Changed 10 years ago by brooks

I think this is caused by 'document.open()' in some iframes.

comment:3 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Regression of [5395].

Changed 10 years ago by Garry Yao

Attachment: 5657.patch added

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review? added

IE mixes up history records of host page and the editing frame, Brooks contribute a secrete secondary param of document.open to help us flying under the radar, note that the patch also fixes a regression of [5450] where it's not able to load wysiwyg mode when switched from source.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

I've committed this one with [5457] due to the severity and urgency of it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy