Opened 7 years ago

Closed 7 years ago

#5516 closed Bug (fixed)

IE8: Toolbar buttons have higher bottom padding

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Toolbar Version: 3.2.1
Keywords: IE8 Confirmed Review+ Cc: Wiktor Walc

Description

This cannot be reproduced with the sample files, but in the online demo of CKEditor, the buttons have an extra padding in the bottom with IE8 in IE8 mode. This is easy to notice in the last row, when compared with the combos.

Attachments (4)

5516.patch (368 bytes) - added by Minh Nguyen 7 years ago.
5516_2.patch (437 bytes) - added by Garry Yao 7 years ago.
ie6_5516_2.png (12.5 KB) - added by Wiktor Walc 7 years ago.
5516_3.patch (449 bytes) - added by Wiktor Walc 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Minh Nguyen

Attachment: 5516.patch added

comment:1 Changed 7 years ago by Minh Nguyen

Keywords: Review? added
Owner: set to Minh Nguyen
Status: newassigned

comment:2 Changed 7 years ago by Garry Yao

Keywords: Review- added; Review? removed

The patch breaks the sample files, I think we should instead check whether some styles from the demo site has caused this problem.

comment:3 Changed 7 years ago by Garry Yao

Keywords: Confirmed Review? added; Review- removed
Owner: changed from Minh Nguyen to Garry Yao
Status: assignednew

After some investigation, it looks for me a IE8 only layout problem instead of any culprit on demo page.

Changed 7 years ago by Garry Yao

Attachment: 5516_2.patch added

comment:4 Changed 7 years ago by Garry Yao

Cc: Wiktor Walc added
Status: newassigned

Changed 7 years ago by Wiktor Walc

Attachment: ie6_5516_2.png added

comment:5 Changed 7 years ago by Wiktor Walc

Keywords: Review- added; Review? removed

Review- because float:left broke IE6 (see attachment).

Changed 7 years ago by Wiktor Walc

Attachment: 5516_3.patch added

comment:6 Changed 7 years ago by Wiktor Walc

Keywords: Review? added; Review- removed

comment:7 Changed 7 years ago by Garry Yao

Keywords: Review+ added; Review? removed

Actually I can't reproduce the problem in IE6 with previous patch, but it's OK to continue with your patch which fixes the problem as well.

comment:8 Changed 7 years ago by Wiktor Walc

Resolution: fixed
Status: assignedclosed

The problem with previous patch occurred in IE6 when I've changed the resize_minWidth setting and made CKEditor smaller with the resize grip.

Fixed with [5424].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy