Opened 12 years ago

Closed 12 years ago

#552 closed Bug (fixed)

Dragging links in Safari clones them

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Normal Milestone: Safari Compatibility
Component: General Version:
Keywords: Cc:

Description

Open the demo and without selecting anything drag the FCKeditor link: it will be cloned, so now there are two links in the editor.

If you select the text of the link then dragging behaves correctly and just moves the content to the new position.

If someone else can confirm it and it isn't already reported by someone else (I didn't found it) we must report it in the webkit tracker.

Change History (4)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe Pending added

I'm not able to reproduce this on. Tested with WebKit's nightly and Safari 3 for Mac and Windows.

When clicking and dragging, a text selection is done instead, as expected. Do you still have this behavior Alfonso?

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Yes, I'm using r22084 and it does behave as I said. I've uploaded a demo movie at http://www.martinezdelizarrondo.com/drag.htm

The fist click below the text is only to focus the window, and then I click the link, drag it and then drop it, all with the mouse or the trackpad and the link is cloned.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe Pending removed

I'm really not able to reproduce it. I've tried with the Mac and Win nightlies of WebKit, and both worked as expected, starting a text selection when dragging.

You have provided a movie of it, so I really believe you. Maybe someone else can confirm it.

comment:4 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: newclosed

I think that we can close this one:

Something that looked strange to me was that the "links are clickable" was closed as fixed, but I still can click them in the Mac, the key is that I haven't installed there the Safari 3 beta; and the fix according to the webkit bug is there, not in webkit. (and after Safari is updated to the beta, the nightly webkits use that, so the bug is fixed also in the webkit nightlies)

And in windows I did install the beta and that problem didn't appear and also I wasn't able to drag the links like described here, so we just have to be sure that both webkit and Safari are updated to really test the problems.

After updating the Mac to Safari 3 beta it works fine.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy