Opened 12 years ago

Closed 12 years ago

#553 closed Bug (fixed)

Safari: "Remove Format" transforms spaces to U+00A0

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Normal Milestone: Safari Compatibility
Component: Core : Styles Version:
Keywords: Cc:

Description

Calling RemoveFormat on Safari transforms the spaces (U+0020) to NON-BREAK SPACE (U+00A0).

Slightly related to http://bugs.webkit.org/show_bug.cgi?id=11947

Change History (4)

comment:1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

I've added a simplified test case in [366] so we can file it. It seems to be a regression because the shipped Safari doesn't have this bug.

In fact it's a regression in r21214. r21200 works fine

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [774].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy