Opened 9 years ago

Closed 9 years ago

#5526 closed Bug (invalid)

Ckeditor 3.2: Not Upload in IE

Reported by: AMGreen Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: Pending Cc: amgreen@…

Description

I have not Upload Pictures and Files in Ckeditor 3.2 in IE all version

Error start in function setUrl in line 356

355 var dialog = this._.filebrowserSe.getDialog(),
356 targetInput = this._.filebrowserSe[ 'for' ],
357 onSelect = this._.filebrowserSe.filebrowser.onSelect;

from file \_source\plugins\filebrowser\plugin.js (source files) and this not work orig file ckeditor.js (not source files)

Change History (3)

comment:1 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added
Milestone: CKEditor 3.x

The demo works fine for me in IE8.

Can you provide the steps to reproduce the problem?

comment:2 Changed 9 years ago by AMGreen

Now check Ckeditor 3.2.1. This Bug still have.

In ckeditor.com/demo not have bug

I edit this files in my site.

config.js add two lines

config.filebrowserUploadUrl='ckeditor/filemanager/connectors/php/upload.php';
config.filebrowserImageUploadUrl='ckeditor/filemanager/connectors/php/upload.php?type=Images';

.htaccess add two lines

CharsetDisable On
AddDefaultCharset utf-8

my file upload.php return:

<script type="text/javascript">
window.parent.CKEDITOR.tools.callFunction(2,"/Upload/php.gif","Upload"); 
</script>

In addition, all the original files

comment:3 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: invalid
Status: newclosed

The problem is in your upload.php that isn't following the docs http://docs.cksource.com/CKEditor_3.x/Developers_Guide/File_Browser_%28Uploader%29

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy