Opened 9 years ago

Closed 9 years ago

#5574 closed Bug (fixed)

SCAYT doesn't get refreshed after command

Reported by: Garry Yao Owned by:
Priority: Low Milestone: CKEditor 3.3
Component: UI : Spell Checker Version:
Keywords: Confirmed Cc: WebSpellChecker.net

Description

Reproducing Procedures

  1. Open any of the sample page and load the editor with the following content and selection;
    va^lid
    
  2. Enable SCAYT and waiting for SCAYT to be activated.
  3. Click on table command to insert a default table in position.
    • Actual Result: The splitted word is not get marked.
    • Expected Result: SCAYT should reflect the correct status after the command.

Change History (4)

comment:1 Changed 9 years ago by Garry Yao

This also apply to other commands like 'Link' and 'SpecialChar'. Current SCAYT is registering refresh behavior on 'insertHtml' and 'insertElement', while some of our command could modify DOM directly without using the above APIs. It's recommended that SCAYT could also perform refresh on each recorded modification ( using the 'editor::saveSnapshot' event).

comment:2 Changed 9 years ago by WebSpellChecker.net

We're not able to reproduce the problem on trunk. We're going to implemet version of plug-in which perfroms refresh on 'editor::saveSnapshot' event.

comment:3 Changed 9 years ago by WebSpellChecker.net

It the steps to reproduce please use word

missp^elled

instead of

va^lid

SCAYT reflects the correct status after the command. Words va and lid exist in dictionary.

comment:4 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: newclosed

The bug is fixed by recent SCAYT core updates.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy