Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#5580 closed Bug (fixed)

Maximize does not work properly in the Office 2003 and V2 skins

Reported by: Sa'ar Zac Elias Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.4
Component: UI : Toolbar Version: 3.0.1
Keywords: Confirmed HasPatch Review+ Cc: comp615@…

Description

Steps to reproduce

  • Go to the skins demo or the skins sample page.
  • Click on the Maximize button on the editors with the Office 2003 and V2 skins.

Notice that there is a space at the bottom and you can see other editor's toolbar buttons.
Tested with IE 8 and FF 3.6.3.

Attachments (1)

5580.patch (914 bytes) - added by Charlie 10 years ago.
Altered maximiser plugin to add the maximised class before calling the resize handler. See comments for more

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Garry Yao

Component: UI : SkinsUI : Toolbar
Keywords: Confirmed added
Milestone: CKEditor 3.3CKEditor 3.4

comment:2 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Charlie

Attachment: 5580.patch added

Altered maximiser plugin to add the maximised class before calling the resize handler. See comments for more

comment:3 Changed 10 years ago by Charlie

Cc: comp615@… added
Keywords: HasPatch Review? added

Fixed the plugin to add the CSS attribute maximized BEFORE calling the rezize handler, since changing CSS properties (namely hiding the resize grip) can potentially alter the size of the header/footer areas, meaning the text editor would not be made large enough.

This bug would also cause any skin which has a different maximized header or footer size from normal to be displayed improperly.

comment:4 Changed 10 years ago by Tobiasz Cudnik

Thank you for the patch, we will review it as soon as possible.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

@comp615, it's a nice catch ;) It fixes the problem and doesn't bring any risk with the change.

I was not able to apply the patch directly. I did it manually instead. Please be sure to create patches from the root of our SVN trunk, with updated local copies.

comment:6 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [5675].

comment:7 Changed 10 years ago by Tobiasz Cudnik

Committed into correct branch with [5699].

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy