Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5603 closed Bug (invalid)

PASTEFROMWORD: Should use the current editors configuration when reading config 'pasteFromWordCleanupFile'

Reported by: mattis Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.2.1
Keywords: HasPatch Cc:

Description

In the current implementation, the pastefromword plugin loads the past from word cleanup file based on the global CKEDITOR's config object. It should use the current editor instead.

Patch supplied.

Attachments (1)

plugin.js.patch (1.1 KB) - added by mattis 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by mattis

Attachment: plugin.js.patch added

comment:1 Changed 7 years ago by mattis

s/past/path

comment:2 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Keywords: HasPatch added

comment:3 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.5.2

comment:4 Changed 7 years ago by Garry Yao

Resolution: invalid
Status: newclosed

It's actually by design, we believe that there should be a consistent way of processing word paste result otherwise user might get confused, the patch doesn't work as "CKEDITOR.cleanWord" - the processor function was by default made as globally shared among instances.

As a workaround, we recommend you to branch your processing logic for different editor inside the function itself:

CKEDITOR.cleanWord = function( data, editor )
{
	if ( editor.name == '...' )
		data = ...
	else
		data = ...
	
	return data;
};

comment:5 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.5.3
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy