Opened 9 years ago

Closed 7 years ago

#5604 closed Bug (invalid)

Headings in br-mode change whole text instead of only the selection

Reported by: ipzerm Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: business@…

Description

This was fixed in the old FCKeditor (I even found an old ticket for it). It would be great if you can fix it in ckeditor as well, as this is really important for us.

Other people reported the same in the ckeditor-Community already, e.g. this entry:

"We are using CKEditor in br-mode for various reasons. And we want to give the users the ability to insert h1,h2,h3 tags as headings in the text.

Problem is, when we are not running in p-mode then it's impossible to insert h-tags on selected text as a heading. Is there any way we can put h-tags on selected text in CKEditor?"

Change History (3)

comment:1 Changed 9 years ago by maxae

Cc: business@… added

Any update on this bug? It's happening for me, and I was able to replicate it using the demo site http://ckeditor.com/demo

When you select text and try to apply Heading 1, it applies the heading to the entire paragraph.

comment:2 Changed 7 years ago by jvns

I'm also currently experiencing this issue.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

This is how CKEditor (and FCKeditor) works by design.

Perhaps H1 style was changing the selection in older versions of FCKeditor but since FCKeditor 2.5 it is working the same way as in CKEditor. Please have a look at http://dev.ckeditor.com/ticket/68

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy