Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#5634 closed Bug (fixed)

In IE 8 Compatibility Mode need to click twice to edit

Reported by: pavelgj Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.1
Keywords: Confirmed IE Cc:

Description

IE 8 Compatibility Mode (and possibly IE 7) have to click twice inside the editor to be able to edit. On first click the blinking cursor appears, but contents are not editable. Have to click the second time.

How to replicate:

Open http://nightly.ckeditor.com/5430/_samples/replacebyclass.html in IE8 and enable Compatibility View. Click once inside the editor and try editing.

Attachments (1)

5634.patch (581 bytes) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by Garry Yao

Keywords: Confirmed IE added
Milestone: CKEditor 3.4
Priority: HighNormal

The problem only occurs when clicking outside body content.

comment:2 Changed 7 years ago by brooks

Owner: set to brooks
Status: newassigned

comment:3 Changed 7 years ago by brooks

Owner: brooks deleted
Status: assignednew

Changed 7 years ago by Garry Yao

Attachment: 5634.patch added

comment:4 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned
Version: 3.1

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

I'm not able to reproduce it on the nightly, but it happens on trunk. To see the problem you have to click the empty space after the editor contents, not the into the text directly.

comment:6 Changed 7 years ago by pavelgj

I'm still able to reproduce this on nightly (IE8 in Compatibility Mode):

http://nightly.ckeditor.com/5708/_samples/replacebyclass.html

Yes, to reproduce you need to click outside of content (ex. just below).

Thanks for looking into this.

-- Pavel Jbanov

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignedreview

comment:8 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with [5738].

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

I've reverted [5738] and implemented a different solution for this ticket with [5760], due to #5280.

comment:11 Changed 6 years ago by Frederico Caldeira Knabben

Keywords: NeedsTest added

comment:12 Changed 6 years ago by pavelgj

I'm seeing strange behaviour on nightly in IE8-compat: when clicking below the text, it puts the cursor at the beginning of the text instead of at the end. In Chrome it puts the cursor on the last line and X of the click (same in FF).

comment:13 Changed 5 years ago by Frederico Caldeira Knabben

Keywords: NeedsTest removed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy