Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#5667 closed Bug (fixed)

Pasting in an RTL page causes the editor to scroll erratically

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: Core : Pasting Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

Though reproducible in all browsers, the bug is most noticable in IE.

Steps to reproduce

  • Open a sample page in RTL mode.
  • Paste some content inside the editor.

Notice that the scrollbar behaves erratically. As long as you paste more data or faster, longer the time the scrollbar appears.
This bug does not occur in 3.2.1.

Attachments (1)

5667.patch (1.1 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Garry Yao

Milestone: CKEditor 3.3

Can you please provide more details than 'erratically'?

comment:2 Changed 10 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.3

Sorry, I mistakenly thought the cause to this problem is the RTL page, but it seems that the cause is the contentsLangDirection : 'rtl' definition.
If you paste you'll notice that the horizontal scrollbar is jumping to the left. You will also notice that there is an element selected and focused.
Regression of [5224], so targeting to 3.3.

Changed 10 years ago by Garry Yao

Attachment: 5667.patch added

comment:3 Changed 10 years ago by Garry Yao

Keywords: Confirmed Review? added
Owner: set to Garry Yao
Status: newassigned

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5493].

comment:6 Changed 8 years ago by wizztjh

It still cause problem when the ckeditor is on the middle of scrollbar. After delete the

pastebin.setStyle( this.config.contentsLangDirection == 'ltr' ? 'left' : 'right', '-1000px' );

it is fine. Why we need that line of code?

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy