Opened 9 years ago

Closed 6 years ago

#5695 closed Bug (fixed)

Context menu with SCAYT's options always appears above the selected text

Reported by: Sa'ar Zac Elias Owned by:
Priority: Normal Milestone:
Component: UI : Context Menu Version: SVN (CKEditor) - OLD
Keywords: Cc:

Description

Steps to reproduce

  • Load a sample with the following content:
    <p>
    	<a href="#">mispelled</a></p>
    
  • Wait for SCAYT to mark the link.
  • Right click on the link.

Notice that some options are hidden because the context menu is opened above the text and not beneath it.

Attachments (1)

CKE.PNG (24.8 KB) - added by Sa'ar Zac Elias 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Pending added
Milestone: CKEditor 3.4

Sorry, I can't see the problem. Can you provide us a screenshot of it?

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net added

Changed 9 years ago by Sa'ar Zac Elias

Attachment: CKE.PNG added

comment:3 Changed 9 years ago by Sa'ar Zac Elias

Note that I was only able to reproduce the bug in FF and I was using the replacebycode sample.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net removed
Keywords: Confirmed added; Pending removed

The problem here is the limited windows size, which cuts the context menu when it opens to the top. We must make it in a way that the top border of it will be always visible, eventually cutting it's bottom part.

This is a generic issue, not related to SCAYT only.

comment:5 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I haven't been able to reproduce this in latest CKEditor 4.2. Issue seems to be fixed.

@Saare id you are still able to reproduce this problem please leave a comment.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy