Ticket #5696 (closed Bug: fixed)

Opened 4 years ago

Last modified 22 months ago

IE : Cursor moves to the start of paragraph in the Pasted Text

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.2
Keywords: IBM Cc: damo, joek

Description

To reproduce the defect

  1. Open Ajax sample.
  1. Paste the following text in to the Editor "The wisest man has still got something new to learn"

Expected Result: Data will be pasted with the cursor stayed at the end of the pasted line.

Actual Result: Data will be pasted with cursor moved to the front of the pasted line

  1. Move cursor to the end of the line with pasted data
  1. Attempt to paste the previous text at the end of the line.

Expected Result: Data will be pasted at the end of the current line.

Actual Result: Data is pasted on a a new line

Tested against IE6&7

Change History

comment:1 Changed 4 years ago by garry.yao

It's related to the browser's native paste feature, we're intended to deal with it at #5309.

comment:2 Changed 4 years ago by JoeK

  • Milestone set to CKEditor 3.4

comment:3 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.4 to CKEditor 3.5

comment:4 follow-up: ↓ 5 Changed 4 years ago by Saare

  • Status changed from new to pending

I'm not able to reproduce the bug on trunk anymore.

comment:5 in reply to: ↑ 4 Changed 4 years ago by satya

Replying to Saare:

I'm not able to reproduce the bug on trunk anymore.

The first issue is not reproducible but the second issue from step 3 is still reproducible.

  1. Move cursor to the end of the line with pasted data
  1. Attempt to paste the previous text at the end of the line.

Expected Result: Data will be pasted at the end of the current line.

Actual Result: Data is pasted on a a new line

comment:6 Changed 4 years ago by garry.yao

  • Milestone CKEditor 3.4.2 deleted

The second case is reproducible, but I'm sure the result depends on browsers quite much, some browser might choose to treated it a new line, while some not, for me in this case the former result is better.

comment:7 Changed 3 years ago by garry.yao

  • Cc changed from damo,joek to damo, joek
  • Component changed from General to Core : Pasting

The result is highly related to the source of the copied content, I could get the desired result (paste appended) with the following steps in all IEs:

  1. Load the editor with following text:
    <p>A single paragraph</p>
    
  2. Select the full paragraph using Select All or click on "p" element of the elements path bar.
  3. Copy with Ctrl-C.
  4. Press End to place cursor at the end of block.
  5. Paste with Ctrl-V.

But it fails if I replicate step.2 in another way:

 2. Select the full paragraph using mouse drag over the entire text range

Anyway, ticket desc. should be updated to be more specific as it's really a case-by-case thing.

comment:8 Changed 22 months ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed

This is no longer reproducible. Tested in CKEditor 3.6.3.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy